Beecrowd 1012-Area solution C, CPP and Python || Beecrowd 1012 || Free Code Center

Beecrowd 1012-Area solution C, CPP and Python

Question link

beecrowd | 1012

Area

Make a program that reads three floating point values: A, B and C. Then, calculate and show:
a) the area of the rectangled triangle that has base A and height C.
b) the area of the radius’s circle C. (pi = 3.14159)
c) the area of the trapezium which has A and B by base, and C by height.
d) the area of ​​the square that has side B.
e) the area of the rectangle that has sides A and B.

Input

The input file contains three double values with one digit after the decimal point.

Output

The output file must contain 5 lines of data. Each line corresponds to one of the areas described above, always with a corresponding message (in Portuguese) and one space between the two points and the value. The value calculated must be presented with 3 digits after the decimal point.

Input SamplesOutput Samples
3.0 4.0 5.2TRIANGULO: 7.800
CIRCULO: 84.949
TRAPEZIO: 18.200
QUADRADO: 16.000
RETANGULO: 12.000
12.7 10.4 15.2TRIANGULO: 96.520
CIRCULO: 725.833
TRAPEZIO: 175.560
QUADRADO: 108.160
RETANGULO: 132.080

Beecrowd 1012-Area solution in C

Solution :

#include<stdio.h>

int main() {
double A,B,C,t,pi,c,tra,s,rec;
scanf("%lf%lf%lf",&A,&B,&C);
pi=3.14159;
t=.5AC;
c=piCC;
tra=.5(A+B)C;
s=BB; rec=AB;
printf("TRIANGULO: %.3lf\nCIRCULO: %.3lf\nTRAPEZIO: %.3lf\nQUADRADO: %.3lf\nRETANGULO: %.3lf\n",t,c,tra,s,rec);

return 0;

}

Beecrowd 1012-Area solution in Python

import math

A, B, C = map(float, input().split())
pi = 3.14159
t = 0.5 * A * C
c = pi * (C ** 2)
tra = 0.5 * (A + B) * C
s = B ** 2
rec = A * B
print(f"TRIANGULO: {t:.3f}")
print(f"CIRCULO: {c:.3f}")
print(f"TRAPEZIO: {tra:.3f}")
print(f"QUADRADO: {s:.3f}")
print(f"RETANGULO: {rec:.3f}")

Next problem :Beecrowd 1013- The Greatest solution

Leave a Comment

Your email address will not be published. Required fields are marked *

Scroll to Top
NEW TOXIC ROCKET CYCLE DECK in Clash Royale 2023 Best Deck in Clash Royale Best Deck for Arena 8 in Clash Royale Best Hog deck for Pro players Best Clash Royale Deck