Beecrowd 1046 solution || URI – BEECROWD – BEE Online Judge Solution  1046-Game Time || Uri 1046 solution in C, C++

submit link

Beecrowd 1046 solution || URI – BEECROWD – BEE 1046 Solution in C, C++

Question

Game Time

Read the start time and end time of a game, in hours. Then calculate the duration of the game, knowing that the game can begin in a day and finish in another day, with a maximum duration of 24 hours. The message must be printed in portuguese “O JOGO DUROU X HORA(S)” that means “THE GAME LASTED X HOUR(S)”

Input

Two integer numbers representing the start and end time of a game.

Output

Print the duration of the game as in the sample output.Beecrowd 1046

Input SampleOutput Sample
16 2O JOGO DUROU 10 HORA(S)
0 0O JOGO DUROU 24 HORA(S)
2 16O JOGO DUROU 14 HORA(S)

Beecrowd/Uri 1046 solution in C

#include <stdio.h>

int main() {

int a,b;
scanf("%d%d",&a,&b);
if(a==b){
printf("O JOGO DUROU 24 HORA(S)\n");
}
if(b>a){
printf("O JOGO DUROU %d HORA(S)\n",b-a);
}
if(a>b){
printf("O JOGO DUROU %d HORA(S)\n",(b+24)-a);//Beecrowd 1046 solution
}
return 0;
}

Beecrowd/Uri 1046 solution in C++

#include <iostream>
using namespace std;

int main() {
int a, b;
std::cin >> a >> b;

if (a == b) {
cout << "O JOGO DUROU 24 HORA(S)" <<endl;
} else if (b > a) {
cout << "O JOGO DUROU " << b - a << " HORA(S)" <<endl;
} else {
cout << "O JOGO DUROU " << (b + 24) - a << " HORA(S)" <<endl;
}

return 0;
}

Beecrowd/Uri 1046 solution in Python


a, b = map(int, input().split())

if a == b:
print("O JOGO DUROU 24 HORA(S)")

elif b > a:
print(f"O JOGO DUROU {b - a} HORA(S)")
else:
print(f"O JOGO DUROU {(b + 24) - a} HORA(S)")

Previous Post: Beecrowd 1044 solution || Beecrowd 1044 Multiples Solution in C & C++

Leave a Comment